Jump to content
  • Hello visitors, welcome to the Hacker World Forum!

    Red Team 1949  (formerly CHT Attack and Defense Team) In this rapidly changing Internet era, we maintain our original intention and create the best community to jointly exchange network technologies. You can obtain hacker attack and defense skills and knowledge in the forum, or you can join our Telegram communication group to discuss and communicate in real time. All kinds of advertisements are prohibited in the forum. Please register as a registered user to check our usage and privacy policy. Thank you for your cooperation.

    TheHackerWorld Official

PHP8.1.10手动安装教程及报错解决梳理

 Share


Recommended Posts

安装教程参考一:https://www.cnblogs.com/haw2106/p/9839655.html

安装教程参考二:https://www.cnblogs.com/jiangfeilong/p/11143698.html

 

安装php版本8.1.10:https://www.php.net/distributions/php-8.1.10.tar.gz

易错步骤梳理:

1、安装的版本是php8,因此教程中php5注意改为8,配置的地方路径也改一下

2、./configure --prefix=/usr/local/php5  --with-apxs2=/usr/local/Apache2/bin/apxs

其中的Apache2要根据自己的安装路径来修改

 

报错解决1:

make: *** No targets specified and no makefile found. Stop.

这是因为缺少xml2-config文件,解决方案:

sudo apt-get install libxml2
sudo apt-get install libxml2-dev

 

报错解决2:

configure: error: Package requirements (sqlite3 > 3.7.4) were not met:

使用下列命令:

yum -y install sqlite-devel

 

报错解决3:

make: *** [ext/fileinfo/libmagic/apprentice.lo] Error 1

指令改为:

./configure --disable-fileinfo --prefix=/usr/local/php --with-apxs2=/usr/local/Apache2/bin/apxs #指定Apache2−−with−apxs2=/usr/local/apache2/bin/apxs——指定Apache2

然后再次编译安装

Link to post
Link to comment
Share on other sites

 Share

discussion group

discussion group

    You don't have permission to chat.
    • Recently Browsing   0 members

      • No registered users viewing this page.
    ×
    ×
    • Create New...